Ongoing System Maintenance

Incident Report for aXcelerate

Resolved

Maintenance complete
Posted May 24, 2026 - 07:28 AEST

Monitoring

We are expecting the maintenance to be finished by 7:30 AM AEST
Posted May 24, 2026 - 05:56 AEST

Update

We are continuing to investigate this issue.
Posted May 24, 2026 - 05:33 AEST

Investigating

Maintenance is still ongoing. We will update this page when it is complete.
Posted May 24, 2026 - 05:31 AEST
This incident affected: aXcelerate Production, Reporting System, Workflow, Online Assessments, Learner Portal, Support services, External Integration, and Mobile Apps.