Support Live Chat is currently unavailable
Incident Report for aXcelerate
Resolved
The Support Live Chat is now operational. We appreciate your patience while the issue was resolved.
Posted Jun 11, 2021 - 09:49 AEST
Investigating
Our Support Centre Live Chat is currently unavailable due to an issue with Zendesk. If you require support, please submit a support request via the Support Centre, or give us a call on (07) 3215 8888.
Posted Jun 11, 2021 - 09:24 AEST
This incident affected: Support services.