System Performance Issue
Incident Report for aXcelerate
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 11:43 AEST
Investigating
We have received reports of slower than expected system performance and are currently in the process of investigating.
Posted Dec 04, 2019 - 11:38 AEST
This incident affected: aXcelerate Production.