Merge Duplicate Contacts error
Incident Report for aXcelerate
Resolved
The cause of this issue has been identified and the issue has been resolved.
Posted Sep 30, 2019 - 12:14 AEST
Update
We are continuing to investigate this issue. We will provide further updates as soon as possible.
Posted Sep 30, 2019 - 11:46 AEST
Investigating
We are currently investigating an issue with the Merge Duplicate Contact tool. We will provide a further update as we have further information.
Posted Sep 30, 2019 - 10:35 AEST
This incident affected: aXcelerate Production.