System Performance Issue
Incident Report for aXcelerate
Resolved
This incident has been resolved and we are monitoring the system.
Posted Mar 26, 2020 - 11:04 AEST
Investigating
We have received reports of slower than expected system performance and are currently in the process of investigating.
Posted Mar 26, 2020 - 10:58 AEST
This incident affected: aXcelerate Production.