Workflow System
Incident Report for aXcelerate
Resolved
This issue has been resolved
Posted Mar 30, 2020 - 12:40 AEST
Investigating
We have identified an issue with the Workflow System and we are currently working to get this resolved.
Posted Mar 30, 2020 - 12:15 AEST
This incident affected: aXcelerate Workflow.