aXcelerate offices experiencing Internet downtime
Incident Report for aXcelerate
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 10:03 AEST
Investigating
We are currently experiencing internet issues at our Milton head office. aXcelerate should remain unaffected, however our support services may be impacted due to this issue.
We apologise for the inconvenience.
Posted Mar 02, 2021 - 08:16 AEST
This incident affected: Support services.